Equifax minor outage
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 08:30 PDT
Monitoring
Equifax is experiencing a minor outage currently which is impacting our ability to pull credit reports. We are monitoring the situation and will update this page as the situation progresses.
Posted Oct 01, 2021 - 17:14 PDT
This incident affected: Lendesk Enterprise & Gateway (Credit Pull (Equifax)) and Finmo (Credit Pull (Equifax)).