Multiple lender responses from TD
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 09:15 PDT
Investigating
TD is currently investigating the cause for sending out multiple responses for the same deal over and over. You can continue to submit to Td as no submissions are impacted.
Posted Jul 08, 2022 - 12:15 PDT