Issue with pulling Equifax credit reports
Incident Report for Lendesk Technologies
Resolved
Equifax has resolved the issue.
Posted Jun 04, 2020 - 16:16 PDT
Investigating
Equifax is currently experiencing a technical issue which impacts pulling credit reports on Lendesk. Equifax is investigating and will advise once it is fixed.
Posted Jun 04, 2020 - 14:41 PDT
This incident affected: Spotlight Submit & Alternative Gateway (Credit Pull (Equifax)).