Issue with Lender: Bridgewater Bank
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 14:17 PDT
Monitoring
A fix has been deployed by Filogix. We are currently monitoring the situation to ensure all issues have been addressed.
Posted May 28, 2020 - 16:13 PDT