Reports of FxDirect Outage
Incident Report for Lendesk Technologies
Resolved
Finastra has resolved their issue. Submissions are working as expected.
Posted Oct 23, 2020 - 08:31 PDT
Investigating
We are currently investigating reports of an FxDirect outage. We have reached out to Finastra for assistance.
Posted Oct 23, 2020 - 06:40 PDT
This incident affected: Lendesk Enterprise & Gateway (Submission).