SnapNoa unable to process requests
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted May 19, 2022 - 14:46 PDT
Identified
Please note that SnapNOA is currently experiencing technical difficulties and are unable to process orders at this time. They hope to have this resolved soon and will provide an update when they are able. Please hold off on submitting any new orders.
Posted May 19, 2022 - 08:20 PDT
This incident affected: Finmo (Snap NOA).