Equifax Credit pull down
Incident Report for Lendesk Technologies
Resolved
Equifax has advised that the issue has been resolved.
Posted Oct 04, 2022 - 14:47 PDT
Investigating
Equifax is experiencing a minor outage currently which is impacting our ability to pull credit reports . We are monitoring the situation and will update this page as the situation progresses.
Posted Oct 04, 2022 - 13:59 PDT
This incident affected: Lendesk Enterprise & Gateway (Credit Pull (Equifax)) and Finmo (Credit Pull (Equifax)).