Issue with Equitable Bank
Incident Report for Lendesk Technologies
Resolved
Equitable has resolved the issue.
Posted Jan 08, 2021 - 17:30 PST
Monitoring
Equitable Bank is back up and operational, we'll continue to monitor its status before resolving.
Posted Jan 08, 2021 - 14:35 PST
Investigating
Equitable Bank is currently experiencing technical issues which are affecting submissions.
Posted Jan 08, 2021 - 12:46 PST
This incident affected: Lender Connections (Equitable Bank).