Issue with submissions to Equitable Bank
Incident Report for Lendesk Technologies
Resolved
Equitable Bank has resolved the issue
Posted Jun 17, 2020 - 16:27 PDT
Monitoring
Submission to Equitable Bank is back up and operational, we'll continue to monitor its status before resolving.
Posted Jun 17, 2020 - 12:11 PDT
This incident affected: Lender Connections (Equitable Bank).