Issue with Document uploads

Incident Report for Lendesk

Resolved

Resolved
Posted Sep 03, 2024 - 10:15 EDT

Update

We are continuing to investigate this issue.
Posted Sep 03, 2024 - 10:15 EDT

Investigating

We are currently investigating an issue with the document uploads which is impacting broker and borrower end uploads.
Posted Sep 03, 2024 - 09:36 EDT
This incident affected: Finmo (Document Uploads and Conversion).