Issue with submissions to Scotiabank
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted Mar 22, 2020 - 21:16 PDT
Identified
The ability to submit to Scotiabank is currently blocked.

The issue has been identified and is in the process of being resolved.
Posted Mar 22, 2020 - 18:29 PDT
This incident affected: Lendesk for Brokers (Submission).