Issue with submissions to Equitable Bank
Incident Report for Lendesk Technologies
Resolved
Equitable Bank has resolved the issue. Thank you for you patience.
Posted Mar 31, 2020 - 17:15 PDT
Investigating
We are currently looking into an issue regarding submissions to Equitable Bank.
Posted Mar 31, 2020 - 08:48 PDT
This incident affected: Lendesk Enterprise & Gateway (Submission).