SnapNoa service disruption

Incident Report for Lendesk Technologies

Resolved

This incident has been resolved.
Posted Aug 30, 2022 - 10:50 PDT

Identified

Please note that SnapNOA is experiencing a sudden service disruption . To prevent another large backlog of orders, they have made the decision to turn off ordering for now. Thank you for your patience and understanding.
Posted May 26, 2022 - 12:46 PDT