Finmo 'Push to expert' is down
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted Aug 03, 2022 - 11:54 PDT
Investigating
We have identified an issue that is impacting submissions to 'Expert' from the compliance section. We will continue to update this status page. If you have received a submission error, please do not re-submit until this has been resolved.
Posted Aug 02, 2022 - 09:57 PDT
This incident affected: Finmo (Push to Filogix Expert).