Issue with submissions to Haventree
Incident Report for Lendesk Technologies
Resolved
We have resolved the issue.
Posted Aug 07, 2020 - 15:05 PDT
Investigating
We are currently investigating an issue with submission which could be affecting submissions to Haventree.
Posted Aug 07, 2020 - 09:08 PDT
This incident affected: Lender Connections (Haventree Bank(fka Equity Fin)).