Issue with submission to MCAP lenders
Incident Report for Lendesk Technologies
Resolved
The validation issue regarding LOT size for submission to MCAP has now been resolved.
Posted Jan 28, 2021 - 09:26 PST
Identified
We have identified a validation issue affecting submissions to MCAP. Please enter a LOT size on the subject property for all submissions to MCAP lenders
Posted Jan 22, 2021 - 17:32 PST