Issue with Submissions to Home Trust
Incident Report for Lendesk Technologies
Resolved
Home Trust has implemented a fix for the issue. This incident is now resolved.
Posted May 31, 2020 - 12:19 PDT
Identified
Home Trust has identified the issue and they are working on a fix.
Posted May 30, 2020 - 12:29 PDT
Investigating
Home Trust is experiencing a connectivity issue and is currently down for submissions. We are working with the Home Trust team to resolve this issue.
Posted May 30, 2020 - 11:39 PDT
This incident affected: Lender Connections (Home Trust).