Issue with Submissions to Equitable

Incident Report for Lendesk

Resolved

This incident has been resolved.
Posted Nov 15, 2022 - 16:25 EST

Investigating

Equitable is experiencing a server connectivity issue and is currently down for submissions. We are working with the Equitable team to resolve this issue.
Posted Nov 15, 2022 - 15:58 EST