Issue with Equitable Bank
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted May 21, 2020 - 14:58 PDT
Identified
Equitable Bank has implemented a fix and we are testing the connection.
Posted May 21, 2020 - 14:28 PDT
Investigating
Equitable Bank is not accepting submissions or returning decisions at this time. We are investigating the issue.
Posted May 21, 2020 - 09:50 PDT
This incident affected: Lender Connections (Equitable Bank).