Equifax Credit Report Pull Service Degradation
Incident Report for Lendesk Technologies
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 14:50 PST
Investigating
Equifax is experiencing a minor outage currently which is impacting our ability to pull credit reports. We are monitoring the situation and will update this page as the situation progresses.
Posted Jan 13, 2022 - 12:55 PST
This incident affected: Lendesk Enterprise & Gateway (Credit Pull (Equifax)) and Finmo (Credit Pull (Equifax)).