Issue with Community Trust
Incident Report for Lendesk Technologies
Resolved
This issue has been resolved.
Posted May 22, 2020 - 10:40 PDT
Identified
An issue has been identified where applications submitted with blank current addresses are not received by Community Trust. We recommend reviewing your application to make sure that you have entered a current address for all applicants. Lendesk and Community Trust are currently working on improvements.

Thank you for you patience and understanding.
Posted Apr 21, 2020 - 16:49 PDT
This incident affected: Lender Connections (Community Trust).