Issue with email notifications
Incident Report for Lendesk Technologies
Resolved
Mandril have resolved the issue.
Posted Dec 15, 2020 - 11:01 PST
Investigating
Mandrill US West is currently experiencing an outage which is affecting email notifications in Lendesk.
Posted Dec 14, 2020 - 10:19 PST
This incident affected: Supporting Services (Mandrill US West).